Language Selection

English French German Italian Portuguese Spanish

Local Privilege Escalation Vulnerability Discovered in snap-confine

Filed under
Security
Ubuntu

Blaming "Linux"

  • Vulnerability in Linux program enables local privilege escalation, researchers report | VentureBeat

    A newly disclosed vulnerability in a Linux program can be exploited for local privilege escalation — and ultimately to acquire root privileges, researchers at cybersecurity vendor Qualys said today.

    The vulnerability (CVE-2021-44731)—which affects Canonical’s Snap system for packaging and deploying software—is not remotely exploitable. However, “if an attacker can log in as any unprivileged user, the vulnerability can be quickly exploited to gain root privileges,” the researchers said in a blog post.

Shoddy media pretending Snap is part of "Linux"



Escalation only

Calling Snap "Linux"

Ubuntu vulnerabilities allow escalation to root: time to patch

  • Ubuntu vulnerabilities allow escalation to root: time to patch [Ed: Not as bad as they make it sound]

    Ubuntu has patched multiple vulnerabilities, some of which allow any unprivileged user to gain root privileges on the vulnerable host. Two, in snap-confine (a SUID-root program that is installed by default on Ubuntu) were reported by security firm Qualys, which admitted that finding and exploiting them had been “extremely challenging (especially in a default installation of Ubuntu), because snap-confine uses a very defensive programming style, AppArmor profiles, seccomp filters, mount namespaces, and two Go helper programs.”

Linux FUD by Microsoft booster Sofia Wyciślik-Wilson

  • Ubuntu and other Linux distros at risk from Oh Snap! More Lemmings security exploit [Ed: FUD by Microsoft booster Sofia Wyciślik-Wilson]

    Security researchers from Qualys have issued a warning about a Local Privilege Escalation Vulnerability Discovered in the snap-confine function of Canonical's Snap package manager.

    Known as Oh Snap! More Lemmings and tracked as CVE-2021-44731, the collection of security flaws can be exploited to gain root privileges.

"LinuxInsider" participates in FUD against "Linux" (Snap etc.)

  • New Cloud Cybersafety, Malware Miseries, Snap Snafus Lavish Linux

    Qualys Research Team discovered multiple vulnerabilities in the snap-confine function on Linux operating systems. The most important of which can be exploited to escalate privilege to gain root privileges.

    Successful exploitation of this vulnerability allows any unprivileged user to gain root privileges on the vulnerable host. Qualys security researchers have been able to independently verify the vulnerability, develop an exploit, and obtain full root privileges on default installations of Ubuntu.

    The Qualys Research Team confirmed the vulnerability. Then it engaged in responsible vulnerability disclosure and coordinated with both vendor and open-source distributions in announcing this newly discovered flaw.

    Snap is a software packaging and deployment system used in Linux distributions. Its packages make it easy to install applications with all their dependencies included to run on all major Linux distributions.

    Snap has become reasonably widespread in the Linux world with a number of major vendors distributing packages using it. While any exploit that can give root access is problematic, being a local exploit reduces the risk somewhat, noted Mike Parkin, engineer at Vulcan Cyber.

Oh, Snap! Security Holes Found in Linux Packaging System

  • Oh, Snap! Security Holes Found in Linux Packaging System

    Canonical‘s snap, like Red Hat‘s flatpaks, are container-based Linux software packaging and deployment programs. While snaps are most strongly associated with Ubuntu Linux, it’s used to distribute and install Linux programs over many Linux distributions. And, alas, the Qualys Research Team, has found several hard-to-find but nasty snap Linux security problems including the Oh Snap! More Lemmings Exploit.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

More in Tux Machines

digiKam 7.7.0 is released

After three months of active maintenance and another bug triage, the digiKam team is proud to present version 7.7.0 of its open source digital photo manager. See below the list of most important features coming with this release. Read more

Dilution and Misuse of the "Linux" Brand

Samsung, Red Hat to Work on Linux Drivers for Future Tech

The metaverse is expected to uproot system design as we know it, and Samsung is one of many hardware vendors re-imagining data center infrastructure in preparation for a parallel 3D world. Samsung is working on new memory technologies that provide faster bandwidth inside hardware for data to travel between CPUs, storage and other computing resources. The company also announced it was partnering with Red Hat to ensure these technologies have Linux compatibility. Read more

today's howtos

  • How to install go1.19beta on Ubuntu 22.04 – NextGenTips

    In this tutorial, we are going to explore how to install go on Ubuntu 22.04 Golang is an open-source programming language that is easy to learn and use. It is built-in concurrency and has a robust standard library. It is reliable, builds fast, and efficient software that scales fast. Its concurrency mechanisms make it easy to write programs that get the most out of multicore and networked machines, while its novel-type systems enable flexible and modular program constructions. Go compiles quickly to machine code and has the convenience of garbage collection and the power of run-time reflection. In this guide, we are going to learn how to install golang 1.19beta on Ubuntu 22.04. Go 1.19beta1 is not yet released. There is so much work in progress with all the documentation.

  • molecule test: failed to connect to bus in systemd container - openQA bites

    Ansible Molecule is a project to help you test your ansible roles. I’m using molecule for automatically testing the ansible roles of geekoops.

  • How To Install MongoDB on AlmaLinux 9 - idroot

    In this tutorial, we will show you how to install MongoDB on AlmaLinux 9. For those of you who didn’t know, MongoDB is a high-performance, highly scalable document-oriented NoSQL database. Unlike in SQL databases where data is stored in rows and columns inside tables, in MongoDB, data is structured in JSON-like format inside records which are referred to as documents. The open-source attribute of MongoDB as a database software makes it an ideal candidate for almost any database-related project. This article assumes you have at least basic knowledge of Linux, know how to use the shell, and most importantly, you host your site on your own VPS. The installation is quite simple and assumes you are running in the root account, if not you may need to add ‘sudo‘ to the commands to get root privileges. I will show you the step-by-step installation of the MongoDB NoSQL database on AlmaLinux 9. You can follow the same instructions for CentOS and Rocky Linux.

  • An introduction (and how-to) to Plugin Loader for the Steam Deck. - Invidious
  • Self-host a Ghost Blog With Traefik

    Ghost is a very popular open-source content management system. Started as an alternative to WordPress and it went on to become an alternative to Substack by focusing on membership and newsletter. The creators of Ghost offer managed Pro hosting but it may not fit everyone's budget. Alternatively, you can self-host it on your own cloud servers. On Linux handbook, we already have a guide on deploying Ghost with Docker in a reverse proxy setup. Instead of Ngnix reverse proxy, you can also use another software called Traefik with Docker. It is a popular open-source cloud-native application proxy, API Gateway, Edge-router, and more. I use Traefik to secure my websites using an SSL certificate obtained from Let's Encrypt. Once deployed, Traefik can automatically manage your certificates and their renewals. In this tutorial, I'll share the necessary steps for deploying a Ghost blog with Docker and Traefik.